Рассадник сумчатой русофобии - AntonTsAU (antontsau) wrote,
Рассадник сумчатой русофобии - AntonTsAU
antontsau

Categories:

Опять ненавидим микротик

Глюкодром хренов.

Накатил я как-то раз, с пару месяцев назад, сиську сосасолы очередной апдейт (6.43.10, если правильно помню) на парочку роутеров 3011 на одном обьекте, и все ВНЕЗАПНО рухнуло. До того работало, после апдейта - хрен. Приходит к нему пакет с внутренней сетки 192.168.2.10 на внутреннюю сетку на втором в паре 192.168.12.99, он его сует в L2TP интерфейс их соединяющие... но при этом НАТит. То есть пакет в впне повялется не как от 192.168.2.10 а от паблик адреса (на котором впн и сидит, разумеется, но какое ему дело через что его пропихивают?). Проваливается на другую сторону, там не очень удивляются, роутят его на 12.99 как есть, там сидит сервер, тот тоже не сильно удивляется, ну мало ли натов в этих интернетах, обрабатывает, отвечает, посылает ответ... правильно, не на 2.10 а на этот паблик адрес, оно и едет куда-то в интернеты, а не в впн! И кирдык, разумеется.

Угробил я в тот раз часа четыре. ВНЕЗАПНО все вылечилось после хЕрургического лечения - накатывания старой версии (6.43.9) и на нее восстановления не бакапа а экспорт-скрипта, взяло и заработало. Я и забил, подумал что баг в новой версии посадили, а в старой оно работоспособно.

А на неделе звонят юзеры и ноют, что у них опять нисасает. Смотрю - а оно опять так же косячит. На все том же 6.43.9. WTF? опять танцы, бубны, принесение в кровавую жертву управдома и все такое... не, никак не идет. Натит и все. В логе видно, что роутер перегрузили, ну думаю какие продвинутые юзеры пошли, выучили таки какую цапу надо дергать, но все равно не сосает. Я уж и так его и эдак, и даже дома собрал модельку из двух хапов, - никак. В продакшне глючит, на модельке все на отличненько. И в микротик написал (но там конечно как всегда молчат). И забил, отложить до более подробного моделирования.

А сегодня, по случаю наличия ничегонеделания, решил еще попробовать, уже ненаучным тыком. Прошелся по всяким настройкам, там поменял, сям поменял, здесь через жопу сделал, там логовалку повесил посмотреть... не, все то же самое. И ВНЕЗАПНО после снятия fast track (использование железячного а не программного свича, 3011 в такое умеет и это включено по умолчанию) в бридже - оно чпок и просралось! И включение фаст трака взатт ничего не поменяло, все равно работает! ЕТМ! FTW! Хреново глючище! Все с ним понятно. Оно явно окосевает когда ребутится (и это были не продвинутые юзеры, а просто вырубали питание...), так как первым делом включает фаст трак, а потом на уже имеющийся прописавшийся где-то путь (там сидит скуд, который примерно раз в секунду высылает пакетик для сервера, соответственно когда роутер перегрузился, то пакет с скуда приходит сразу и тут же суется в интернеты, где и умирает, а впн интерфейс с соответствующим изменением роутинга появляется только через некоторое время) накладывается новый роутинг! Роут меняется, пакетики начинают сыпаться в впн, а то, что их когда-то было надо натить, оно так и продолжает где-то в недрах железки помнить! Мня.

В общем, выдрал я ему этот фаст трак, должно работать. В понедельник проверю уже у юзеров, запустилось ли там у них это все.

НЕНАВИЗХУ.
Tags: НЕНАВИЗХУ, все хреново, лытдыбр, работа, хай мать его тек
Subscribe

  • Post a new comment

    Error

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 5 comments